Bizzare, need serious advice/help!!!



  • Right, basically, my fan went tits up a few eeks ago, then with a sharp hit from a metal bar, worked fine again… then unfotunately died well an truly. Thanks to the assistance of 'mechanic', I managed to obtain a new fan from a breakers at a very fair price, this has now been fitted and working a treat. HOWEVER!

    Garage gave me the car back saying to drive it for a few days and let them know how it is, as the power had gone a bit poor when the fan went... when I start the engine, it starts quicker than ever before, and seems to idle slightly higher than usual, then when accelerating there is a slight whiney noise... almost sounds like a turbo (not coming through speakers - definate engine noise). To really confuse matters, the engine seems to be hiiting peak temperature quicker than it used to too... not a bad thing really, BUT, and this is a major BUT! for some crazy reason, once I have run her for 20 mins or so, sitting in traffic the temp gauge sits where it should, but then when I give any gas the temp gauge rises to about 3/4 rather than only halfway... it stays like that until I ease off... even tested at standstill and still does it... really baffling me and the garage... problem is, their computer can't read the mx, so have found somewhere that can do, but have to wait a whole wek, and of course do not want to fook her anymore than she might already be.

    Anyone had a similiar issue, or heard of something like this? I guess relays would be first port of call, but all have been tested and all seem okay - am quite concerned really. Have read another thread about the air hose being cracked and reducing power, so will check that over tonight, but can't think of any reasons for this crazy behaviour... especially as I am a humble pencil pusher!!

    help me mx ones, your my only hope!!!



  • well you dont need any fancy reeder you can pull flash codes useing a 12v led and a litle bit of wire
    and clear coads by removeing a poticular fuse for 10 seconds



  • And I understood none of that… how does a piece of wire give me codes, plus how do I know it's 12v... what do I connect the wire too? Seriously, I can do stereos blinfolded til cows come home, anything bonnet or engine related, i'm pretty much screwed!!





  • WHAT YOU NEED
    -A bit of wire, I always use those sandwich bag ties and strip the ends.
    -A 12V LED (like the kind you get from halfords)

    HOW TO PULL CODES
    -Turn the car off
    -Find the diagnositics box under the bonnet, its at the rear back of the bay at the firewall. The lid will tell you what each terminal does
    -Put your bit of wire between TEN (test engine) and GND
    -Put the negative of the LED into FEN terminal
    -Put the positive into +B
    -Turn your key to ON position, not started, just ON will do
    -Observe the codes, maybe take a video with your phone if your new to this, but they will repeat anyway

    UNDERSTANDING THE CODES
    -First the LED will light for 3 seconds as a check, then it will display any codes stored.
    -Long flashes (1.5 sec) indicate the number 10, and short flashes (0.4 secs) indicate the number 1

    Translate your codes with this table:

    thanks to club323f for the details

    Somebody PLEASE make this a how to! EVERYONE needs to know this and it is SO HELPFUL in diagnosing problems.



  • Right, so basically I could easily misread code and still have no idea then?

    It mentions that codes are repeated, but to me a flashing light is a flashing light, no matter how long it goes for.

    So am I guessing correct that should I do this right, I will then know where the problem lies, but not what it is? What if there are no problems… will it not flash at all??



  • Also, do I do this while engine hot ie after a drive, or from cold. What if there are multiple faults? Sorry so many questions, I can guarantee that when I try this on saturday, I will probably have many many more!

    Reckon I might need to grow an extra pair of arms for this too!



  • Why would you misread it? It's not the enigma!

    Seriously, not that hard, its a bit like morse code. But you watch the LED, if it flashed long once then 6 short flashes that equals 16. You then look that up on the chart, and see that it is the EGR causing problems. Myself and many others have found it very useful as it greatly narrows down the possibilities.

    If you miss it the first time, turn the car off and then on again then it will start all over again and you can check if you're right, in this example:
    -LED lights up for 3 seconds to show code reading initiation
    -1 Long flash for 1.5 seconds = 10
    -flashes 6 times = 6
    10+6=16

    no flashes = no codes, you've nothing to lose, only to gain, so I wouldn't be so negative about a handy feature for diagnostics!

    EDIT after your last post,
    if there are multiple codes there will be a long gap to separate them
    also ask away dude, glad to hear you'll try it, I find it invaluable at times. Don't worry about when to test for codes, it will store them from all your previous driving.



  • Right, well that makes a bit more sense.. cheers fella…

    If it holds previous codes etc, does that mean that if there was a problem ie fan not working, but is now, it will still bring that code up? Or is it, if I am guessing rightly, that it updates itself so if there was an issue that was fixed, that code would be dropped?



  • UPDATE!

    Nowhere round here sells fricking LED's!!!! Pain in the @ss tbh

    Ended up taking the car to a leccy specialist place down the road - only just crawled there as power seems to decrease every day that passes (my dads mx-3 is so much faster right now - this should not be!)

    Got a call when they had done their thing - NO FAULTS!!! wtf they reckon it could well be the water pump or thermostat now, as engine heats up quick, and top hoses hot, bottom, hoses cold (whatever that means) but would this really drain the power from the engine? and make it more sluggish? They are also going to rinse out the rad, as potentially full of silt - they reckon this could be a factor - is this true?

    Guys, HELP MY BABY!!!



  • It is possible to lose power if the engine is getting that hot… but it would be close to seizing if that was so..

    If the water pump had packed up it would not be circulating the coolant thus causing the cooling system to suffer with hot spots.. top hose bottom hose...

    If i stuck a water pump in i would flush the cooling system. Dont want any foreign objects that might of come of your old pump to screw ya new one up.

    Good luck..



  • my temp gauge stays at 3/4 is there some thing up with it then?



  • My temp gauge sits about a needles width over the half way mark…!



  • yep that's the standard temp Mechanic



  • well just under 3/4 but no loss in performane or any thing,how do i check if its ok?
    thanks lads

    ps got me thinking now or shall i say got a excuse nearly for klze :D



  • Thank you marco

    @d290b6630c=Marco:

    WHAT YOU NEED
    -A bit of wire, I always use those sandwich bag ties and strip the ends.
    -A 12V LED (like the kind you get from halfords)

    HOW TO PULL CODES
    -Turn the car off
    -Find the diagnositics box under the bonnet, its at the rear back of the bay at the firewall. The lid will tell you what each terminal does
    -Put your bit of wire between TEN (test engine) and GND
    -Put the negative of the LED into FEN terminal
    -Put the positive into +B
    -Turn your key to ON position, not started, just ON will do
    -Observe the codes, maybe take a video with your phone if your new to this, but they will repeat anyway

    UNDERSTANDING THE CODES
    -First the LED will light for 3 seconds as a check, then it will display any codes stored.
    -Long flashes (1.5 sec) indicate the number 10, and short flashes (0.4 secs) indicate the number 1

    Translate your codes with this table:

    thanks to club323f for the details

    Somebody PLEASE make this a how to! EVERYONE needs to know this and it is SO HELPFUL in diagnosing problems.

    :D



  • Right, she canny take no more captain - wallet stops spending on the 3 here, so any takers please let me know - have put in sell section - it's a sad sad day, but picking up the new ride on Thursday - ever so slightly more reliable, and cheaper to fix etc… drives like a treat too - a spanking focus st170 - mmmm 8)


Log in to reply
 

Looks like your connection to UK-MX3.COM was lost, please wait while we try to reconnect.