Speedo calibration



  • I fitted some new glow dials in my V6 and I don't think they are measuring the speed properly. I seem to alsways be doing 40mph on my speedo when I keep up with the car in front on a 30mph road. I went through one of those digital signs near my house to test it out and when my speedo was reading 40 it said I was doing 32mph. any idea how to re-calibrate it?



  • is the need getting stuck with the added thickness of the glow dials? Or is it reading everything higher?



  • not sure how to do this but before i installed mine i checked roughly where the rev needle was at certain speeds. noticed that both needles would be parrell at any speed. if thats any help lol



  • My guess is that the tale of the needle is getting stuck on ya glow dials. You need to check for clearance.



  • @f92f718aa5=Mechanic:

    My guess is that the tale of the needle is getting stuck on ya glow dials. You need to check for clearance.

    yes this is a common problem… sometimes people will delicately shave off the bottom of the needles... you can also glue down the dials or use double sided tape to keep them down...

    my speed gauge sticks until about 15 mph still :roll:



  • nope its definatly not sticking as the person who owned the car previously had put in dials from like a fiesta or something and they were all bent anyways so I took them out there is only the thickness of the glow dials. its is reading above what it should be. not sticking anywhere.



  • do you have a 4 cylinder mx-3? maybe the speedo cable went bad or something??



  • No I have the V6.
    It could well be the speedo cable but I just wanted to know if anyone new how to calibrate it before I get any new parts.



  • did you take the needle off? it might be in the wrong place, im sure the glow dials can be put on by working around the needles :?



  • I had to cut the glow dials slightly to get it over the needles as they have such a large tail. If i had realised what a pain they were to do i would of probably not of bothered.


Log in to reply
 

Looks like your connection to UK-MX3.COM was lost, please wait while we try to reconnect.