Plz help my baby mx3 wont start ladz x



  • hi i've got the 92 mx-3 v6
    its bin running a bit shitty for a few weeks .. in the morning it sits at 2000 rpm then will drop to about 500 when warm … but 3 days ago i drove her 2 minz down the road and she didnt feel right but i left her ticking over for 2 minutes and she cut and and will not start again .. also i cant hear the fuel pump kicking in and ive smelt the leads lol and i cannot smell petrol in there .. ive chenged the fuel pump relays today and still nuffink .. plz plz help this dumb blonde as im not into public transport and want my car healthy again hehe xx :oops:



  • i had a simlar problem! mine would stall under load tho!

    try changuing,leads, plugs and distributor! i reconditioned my distributor but is starting to run funny again so am going to do a HEI mod sometime over the next few weeks as i cant afford to buy a new distrobuter at moment due to going on hols next month lol!

    before it died was it missfiring alot?



  • Are you sure you can't hear the fuel pump? when you turn the ignition on you should only hear it for a second while it primes, and it is very faint, try taking the back seat out so you can hear it better, and also make sure the wiring is not burnt out while your there, don't do what i did and pull the seat till it comes off, the clips on the bottom have a pushy thing on the front, if you push that it comes off :lol:

    when mine did it, it was due to the wiring burning out, eventually it just shorted, check the fuse in the box in the engine bay.

    if it is the fuel pump if you leave it for a good few hours then try and turn it over, it should fire, even if it only fires on 2 cylinders before dying completely again it gives you more of an idea what it is, i left mine for 3 days and it actually started for a couple of seconds :shock:



  • i had a close porblem before. the reves would not stable at all. found out to be a connectore at the back of the block under the throttle body. clipped that back in and worked.

    following that will it turn over and try to fire? (would help alot if we know that)

    as said check fuse's and wiring at pump.

    has to be said you sure you got petrol in it. or not filled up with something else??



  • :lol: the diesel hose is too big for the filler, i nearly did it once :oops:



  • lol i maybe blonde but i know petrol from diesel ahha.. and no i havnt put nothing in it and its definatly got petrol in .. and i had the back seat out when listening for the fuel pump .. and nothing xx

    has to be said you sure you got petrol in it. or not filled up with something else??



  • and yes it will crank but will not fire up .doe's not seem to be getting any fuel atall in the head x



  • no hun was not missfiring atall . plus iv'e had a new dizzy put on just a couple of months ago @1531612aa1=simon179:

    i had a simlar problem! mine would stall under load tho!

    try changuing,leads, plugs and distributor! i reconditioned my distributor but is starting to run funny again so am going to do a HEI mod sometime over the next few weeks as i cant afford to buy a new distrobuter at moment due to going on hols next month lol!

    before it died was it missfiring alot?



  • might sound weird, but u parked on a hill?



  • best bet is to get a diognostics kit on it then!

    have u tried changing the battery? ur battery may be dead

    also a long shot but ur ECU may have died :(



  • look at relay for fuel. as she will crank and try to turn over. but no priming on petrol pump.

    so anyone got a mx being stripped the you maybe able to post over a relay from to kerri



  • yes what he said lol … anyone got any parts that may help get her started again would be a great help lol@2320d9f4ac=Valley:

    look at relay for fuel. as she will crank and try to turn over. but no priming on petrol pump.

    so anyone got a mx being stripped the you maybe able to post over a relay from to kerri



  • try dumping some go juice down the throttle body. if it fires then great if not then you know what to do.



  • what are you like with wiring?

    seems as you have the back seat up anyway, try putting a wire from the live terminal on the battery to the (what i can remember) thick black and red one one the fuel pump, you should hear the pump whirling, and it should start with the wire connected and when you turn it over, if you don't hear it then it will either be an earth or the pump is dead

    which relay did you change? theres one under the dash near the ECU too :wink:


Log in to reply
 

Looks like your connection to UK-MX3.COM was lost, please wait while we try to reconnect.