Strange engine problem K8



  • right today was on my way home from work! pulled out of a junction gave it abit too much power and has just been reserfaced so must have been greasy so it was giving it alot of spin it got about 50yards down the road then started like missfiring and wasnt geting any power so i pulled over and lifted the bonnet!

    engine was ticking over and idleing fine just sounded abit lumpy, when i pushed the throttle to give it some revs it would just barble and missfire was asif it was being starved of fuel and wouldnt kick out any revs!

    with slow short revs i managed to build up enough power to get it moving and managed to creep it back to the office!

    any idea what it could be? has propper stumped me this and thought i would aske before i go get my arse slapped by a garage!

    thanks si



  • Does it have a cat convertor fitted, sounds like it might be blocked.

    Give it a thump with ya hand (when cold) and listen. Look at your tail pipe for white bits.

    …...



  • has a cat which seems fine! no white bits either

    just went to it before to fire it up see how it was running this morning and wont fire up

    its trying to and it will get a short bump asif its gna start here and tehr but other than that nothing



  • get much wheel hop on your burnout? It's killer for loosening things. Check all vacuum hoses, intake, spark plug wires, dizzy position. Pulling codes can often take out some guesswork :wink:



  • Check your timing incase it slipped due to over reving.

    :!:



  • @63de598302=Mechanic:

    Check your timing incase it slipped due to over reving.

    :!:

    seems to be running too smooth on idle for it to be the timing!

    when its givien revvs its asif its not getting fuel or not sparking! did teh paper test on teh exhaust and it isnt chuking ne fuel out!



  • I would still check it .. . :!:



  • could cracked dizzy cap with the extra engine vibrations. i did lol was very slight hair like but was missing like a dyson with a bad cold



  • @774ed9861a=Valley:

    could cracked dizzy cap with the extra engine vibrations. i did lol was very slight hair like but was missing like a dyson with a bad cold

    have now come to conclusio its either over fueling or not burning the fuel its been getting so could bell be the dizzy! gna do a service on it, oil, oil filter, ht leads, plugs, fuel filter just to eliminate them and then look at replacing the dizzy if problem consists if that doesnt work il be stumped agen :x



  • HEI mod time!



  • i had the exact same problem it turned out to be my leads try it man



  • @40c31ad770=Marco:

    HEI mod time!

    http://www.uk-mx3.com//forum/viewtopic.php?t=669



  • change spark plugs, it did wonders for my car!!!!!



  • where can i get leads and plugs for my car from internet? all local shops have to order them in so thought i may aswell skip teh middle man an get em off internet nyself lol

    gna give it a full service see what taht does as teh leads seem ot be givin opuit all different resistances! if that doesnt work iwll try changind teh disty and if that doesnt work will geth the maf resistance tested! if taht doesnt work am gna look for a 2.5 haha cus cba spendin money swapin an changing things wen i plan on puttin a bigger engine in in next yr or 2 anyways!



  • defo get a decent set from http://www.fordprobestore.co.uk/store/

    I've heard great things about them, a few of the lads here are running them.

    And a decent set of plugs



  • ngk irridium FTW i got them installed on my klze although i will be taking a video of my engine running soon as im not very happy at all atm i fixed a slight problem with my overfueling but my car dosent sound very healthy at all :(



  • have just ordered some normal ngk leads and pugs for now as if they arent the problem then i have more money to spend trying to find the problem next port of call would be the distrobuter!

    how much am i looking at for one and where would i get them?

    thanks si



  • are you looking for just the cap or the entire thing



  • @e65295e3f1=Valley:

    are you looking for just the cap or the entire thing

    well i dont know to be honest what part usually goes? aparently its a common fault accordin to the american site but they just kepep telling me to check my vacume hoses and i keep telling them i have and its fine but they jus keep telling me again to check them lol so thought would take it into my own hands ask on here an start replacing things cus its annoying me lol



  • on the distributor it would either be the cap or the coil, have you taen the cap off and looked at it? it may be cracked or the points burnt out/corroded, if its the coil, it would work out cheaper doing what i linked you to above

    both the dizzy cap and the components for the HEI mod can be find on probestore


Log in to reply
 

Looks like your connection to UK-MX3.COM was lost, please wait while we try to reconnect.