Warning Lamp Comes on?



  • Hi there,

    Not sure if anyone else has ever had this but…..the warning light which usually indicates the handbrake being on with the (!) symbol - has been coming on when I have been accelerating away from junctions (before you say..... do you take the handbrake off when setting off.....YES) it stays light until you ease off the accelerator - usually when not under as much load....usually only happens when you want a quick get away - its a strange one as it is not an oil light which I would think would mean oil pressure issues - hopefully nothing to worry about but I thought I would ask on this one as I am puzzled......any help or advice would be welcome. My car is a 1.8 V6 and the only engine mods are K&N Cone filter and pipercross breather.

    Thanks



  • dodgy switch more than likely at fault there, it should be under the center console to swap it for another one just to rule that out



  • @c32f9e6963=djmarcopolo:

    dodgy switch more than likely at fault there, it should be under the center console to swap it for another one just to rule that out

    More likely low brake fluid.. check it mate.



  • @2084171fcc=youdirtyfox:

    More likely low brake fluid.. check it mate.

    Gets my vote,



  • Again "what they say" :P You're creating some 'G' when getting away quick! and 'sloshing' your 'LOW' brake fluid to the back of the reservoir allowing the low fluid switch to illuminate the warning light (as it should) At least ya know it works :D
    As Lori C says CHECK IT! and then check for leaks? before you do ANY more "getting away quicks" especially if its only recently started doing it!

    CHECK
    At each of 4 wheels, inner rim should be dust only (dry weather)

    Around master cylinder and servo base.

    Down under battery near ABS pump gubbins

    In cabin around brake pedal push rod.

    Remember, if it doesn't BRAKE…......it will BREAK!!! :shock:

    (might it also be possible if handbrake switch is set sensitive and for the car to 'hunker down' at rear under acceleration for the cables/outers to
    tug slightly on the handbrake lever??? NO??? ah well just a thought? :oops: )



  • totally forgot about brake fluid levels :oops:



  • Ya better get yours checked too if thats the case ya 'tit' :rofl:



  • :rofl:



  • Well - thanks for the advice again - it was indeed low brake fluid level…..no leaks to be seen anywhere though?......It was'nt at the min mark just above so topped up and all sorted. Next moth my car will be getting some pre mot TLC lets hope the car gets through ok ready for the japshow at pod :-)


Log in to reply
 

Looks like your connection to UK-MX3.COM was lost, please wait while we try to reconnect.