High idle after new clutch fitted



  • Hi, Ive just had a new clutch put in by the garage as the old one was slipping. But now the idle RPM is around 1300 to 1500, drops to 1100 when clutch pedal depressed. Surely this is not right! What have they done wrong? Previously the idle was around 700 to 800 ish seemed fine. Any comments gratefully recieved, just wandered if I can do anything simple to sort it. Garage is 20 miles away, they did the clutch on warranty.



  • they probably disconnected the battery while working on it, so the ECU will have reset, should sort itself out, how long have you driven it around since the work was done?



  • just drove back from the garage, about 10 miles down the carraigeway.
    I hope your right, ill take it out tomorrow and see if it settles down. Does a lot need taking apart to change a clutch on these V6 models?



  • Changing a clutch is not a do at home job mate, unless you live in an extensive workshop. Have you checked to see that theres no electrical loads on like air conditioning, rear window heater etc? These will cause the cars idle to increase. Take the car for a 20/30mile run today, see if it settles down.

    Did they do any other work on the car that might have required them to adjust the idle or throttle cable tension?



  • No I gather its not an easy job , just wondered if they have to take off any parts/adjust that may affect the idle afterwards. Ill give it a good run today and update later



  • PROVIDING THE CLUTCH IS WORKING FINE WITH NO NOISES OR SNATCHING I WOULD ASSUME IT IS INSTALLED FINE.

    They have to take quite alot off to change the clutch. They have to remove the gearbox and anything thats in the way to get acces to it.

    I would look at all your induction pipes and vacuum lines to see if any have come off or split etc.

    Then check that all electrical plugs are plugged in correctly.



  • clutch seems to be ok. No slipping anymore, hooray! Performance is much better. Did about 15 miles yesterday and the idle is settling down, was 1100 idle and 750-850 with clutch depressed. Ill continue to monitor today and will check around the engine as per your suggestion.



  • Tak eit back to the garage and tell em to fix it.



  • lol, had same recently on my focus, clutch change and now idle is too low, havent bothered to have it fixed yet, expect it a hose or sensor left un plugged.
    Im sure its nothing major.



  • TPS/IAC anyone?


Log in to reply
 

Looks like your connection to UK-MX3.COM was lost, please wait while we try to reconnect.