Jono's KLZE Project - Turbo Build Begins



  • @845816bd84=jono:

    Dials: (Crappy Pic from Phone)

    Jono

    Umm is your car overheating really bad? or is the needle just messed up?! lol


  • admin

    Lol your the first one to notice that! lol

    When fitting the dials I had to remove the screws from the temp & fuel gauge, when I put them back in (upside down) the clamp fell out so the gauge was not getting a signal and just went right to the top lol

    Fixed now tho

    Jono



  • @ae66798946:

    my old alloys are for sale if anyone is interested, look at the Old Alloys pic above…

    how much are you looking at for them?


  • admin

    @b429e15f8f=burger28:

    how much are you looking at for them?

    Not sure yet, around £20 - £30 each

    Pm me with an offer

    Jono



  • let me know if you have questions for fitting for the piping and all… I can send you pics of the way I did it... dont give up its worth it.



  • that booy install, did it take you long?


  • admin

    @87787339f3=aiden:

    that booy install, did it take you long?

    One day + 3 evenings after work :)

    Jono



  • cool, did you fix the side pieces?


  • admin

    Not fixed to the car yet! At the moment they are jammed in place and secured by some screws to the wood holding the power cap…

    I dont really wanna damage any of the internal trim!

    If anyone is gona be down donny south on the 19th then let me know and we can meet up there also im gona be testing the ZE on the 0-60 strip :)

    I also have some good news... I will have my ZE ECU on saturday, which will be in time for the 0-60 sprint, cant wait to try it :D

    Jono



  • the boot install is really nice, all have a place nice and tidy 8)


  • admin

    Small Update…

    Well the car has had a little work dont lately..

    Changed the Cam Cover Seals - It was leaking oil before and managed to screw up the ignition (oily spark plugs and ht leads is not good!!)

    I didnt change the seals when the engine was out, might I suggest that anyone doing a ZE swap do this before, as the IM is a bitch to get out when its in the bay!

    Besides for £20 its worth it.

    Obviously all new spark plugs and as of last night some brand new 10mm Blue HT leads :D

    I will try to get some pics up today...

    On another note, I have a slight issue with the car still not running right.. I have a feeling I might have a dodgy o2 sensor or 2 :(

    Can I also make a note about www.fordprobestore.co.uk - Excellent fast service :)

    Jono



  • @c3595ddd96=jono:

    Changed the Cam Cover Seals - It was leaking oil before and managed to screw up the ignition (oily spark plugs and ht leads is not good!!)

    This happened to my k8 too, oil on top of the plug. Rear bank of course - IM is a bit of a pita to take off. Think I shall change mine when the ZE arrives. Also trying to decide whether to replace the valve springs & retainers or not. You running ze springs & retainers? Worried about valve dropping due to weak retainers?



  • umm, ive got oil in the front bank of mine
    you said ofcourse to i bein the rear bank
    is the front baddd??



  • no that's good! Rear bank you gotta take of intake manifold. Front bank is a piece of piss! Just be very careful not to overtighten the bolts, they're very low torque setting.


  • admin

    @d26381720b=Marco:

    You running ze springs & retainers? Worried about valve dropping due to weak retainers?

    Yeah I have the standard ze springs & retainers, nah im not worried, im pretty carefull with it, I try not to red line as I have heard that doesnt help..

    I will change them when I get to the engine rebuild for more boost… but for now my focus is building up the parts for the turbo to start with lol

    Yeah my back bank was the worst with oil... it seems the seals around the spark plug holes dont last that long, and they are the first to go!

    Jono


  • admin

    New engine bay pic (Needs a clean and polish!!!)

    Jono



  • yum :D
    Did you rotate your oil cap for the photo or did it just line up like that? :lol:

    So the stock strut bar fits? Or did you pack it up? Looks like you're missing a bolt :o

    Great work Jono


  • admin

    @d29274129a=Marco:

    Did you rotate your oil cap for the photo or did it just line up like that?

    Lol, well the cap comes with the middle not stuck down! So i did it up tight and put on the middle sticker so it will allways be perfect :D

    @d29274129a=Marco:

    So the stock strut bar fits? Or did you pack it up? Looks like you're missing a bolt :o

    Yeah it fits no problem!! I have a little wear on the pipe that goes from the front cam cover to the back, but other then that it fits nice :)

    As for the bolt… when it removed the strut a few weeks ago to do the cam cover seals I lost one down into the bay -> forgot about it... test drove it with the new leads and heard it fall out on the road, but I didnt find it :(

    When I get time I will nip down the road to the local hardware place, he should have one :D

    Next on the list is possibly replace the o2 sensors, as its not running right, possibly too rich, ive had a look at the inlet etc and all seems to be ok (no splits or leaks) so next is test the o2's and replace if required!! :roll:

    Jono



  • k8 ecu will make you run rich apparently. Could be your problem! You should get a probinator chip. He has a car domain where he explains how to and which k8 ecus it works on.

    Tried pulling codes? should reveal o2 problems. But also you can measure the resistance and manual says what it should be.

    Can't wait to be in your shoes!



  • are u using th egr valve or not i would recommend removing the egr all together and buying the kl31 ecu thats wot ive done in mine and it runs sweet and no warning light either :D although there is a draw back to this which is the ecu is restricted to 118mph but to be fair when will u need to go anyquicker than that. and it deffinatly dosent effect the acceleration to get to that speed beleive me.


 

Copyright 2020 UK-MX3.com | Powered by NodeBB