ENGINE WON'T START



  • Hi,
    I tried uploading photos from tinypic.com and got horribly screwed up.
    I'm not sure that photos will help but if needed please let me know how….
    Thanks



  • Mmmm? I was sure you were going to come back and say it was VAF connector unplugged :?

    1. For the VAF to fail totally would be extreme indeed, I know that if left unplugged! car wont start :oops:
    There are I think 4 resistance checks, on the 5 pins, best done off car as access is v tight,
    a) E2(1)-Vs cone fully closed =200-1000 ohms
    b) E2(1)-Vs cone fulley open =20-800 ohms
    c) E2(1)-Vc . . . . . . =200-400

    THA = air temperature sensor
    d) THA-E2 (2nd) @ -20 .Oc -10000-20000
    0 -4000-7000
    20 -2210-2690
    40 -900-1300
    60 -400-700
    With the unit off and connector facing you and the 'moving' metering cone to the left,the pins are from left to right:
    THA . E2 (1) . E2(2) .Vc . Vs

    I have a diagram, but my scanner is fooked! :shock:

    2. Crank position sensor is a two wire grey plug next/below coolant filler cap,
    Resistance at 20 oC is 520-580 ohms.

    3. Cam shaft and crank speed sensor (RPM) are hidden in dizzy internals, or hall trigger unit using its tech name? no meterable output available!

    The knocksensor as far as i know will NOT prevent your car starting, it is simply a microphone that detects 'knock' or 'pinking', and on detection, sends a signal to ECU which then retards ignition timing via coil output to a point before 'knock occured?

    4. The code pull prob is strange? I have seen other owners having NO output probs too and generally its down to procedure error, and they dont follow up on forum with their progress?
    I dont know the pins as 'numbers', as of the two cars i have, the labels under the lids are lost! I always go to 'names' and cross check with a diagram. (see my posts! still 'NO' replys?)

    Jumper between TEN and GND
    LED between FEN and B+
    12 volt (none flashing!) LED, negative lead in FEN, positive lead in B+
    Insert ignition key and turn to 'ON' only!!! (not start)
    wait at least 6 seconds, LED should light initially and then go out if 'NO' codes stored?
    If codes? will flash in sequences and repeat until ignition turned off!

    5. Total ECU failure is possible but you'd probably have to drown it or short all its pins at once?????

    6. As I understand it, my 'diagnostic' is laid out as follows
    Top row of 4 pins, with gap between two middle pins
    2nd row of 7 pins
    3rd row of 6 pins
    gap
    4th row of 6 pins
    5th row of 4 pins with a chamfered gap of two pins width in middle.

    Used connections as follows:
    top row (left to right) 1st pin is FEN, MEN …...gap..... TEN, B+
    2nd row (far left) 1st pin is GND
    (MEN is not used in code pull)

    If your saying theyre numbered as, 1 top left , 4 top right, and 1st pin of 2nd row is '5'???? It would appear you're jumping 2+5 which is wrong as that is MEN + GND!!! and should be 3 + 5...... TEN + GND!!
    1 and 4 is right for LED, as long as 'positive' leg of LED is in pin 4 (B+)

    CHECK LED's polarity or another one, across a battery's 12volts, it should light constantly??? and make sure enough of the wire is entering the pin locations???

    Well Im about typed out!!! will look in later this week for progress, hope this helps??? :shock:



  • Fantastic reply. Many thanks.
    I will get cracking today to measure as per your post.

    I made an error in the pins listed in my earlier post.

    I connected the jumper wire between pins 3 and 5 (TEN and Ground) with the LED test lamp between 1 and 4 (FEN and +battery) Sorry for any confusion.

    One thing may be relevant. I got my son to turn the key to start while I checked for a spark. I think I noticed a bright spark with the initial firing but weaker sparks thereafter.
    I need to check this but if this is so, might this give some sort of indication?
    When trying to start, the engine tries to fire once and then doesn't fire.
    Is this relevant?
    Thanks again



  • does it run in diagnostic mode?

    It would be strange for something you have not disturbed to just go.

    Check the spark as its going dark and you will see better, put it to a good earth, use a spare plug if you can as its safer.



  • Dont worry about typo error fella, Im pretty sure they'll be a few in my essay too :rofl:

    The initial strong spark then weaker would Imo be a coil/igniter/dizzy cap issue or bad connection/bad earth in the loom somewhere to dizzy?

    Is the little carbon center contact in the dizzy cap intact, clean, free to move? also inspect coil output post for damage buring etc?

    There are also a couple of earth connections on gearbox near starter motor, you could undo, inspect, wire brush clean, refit connections. Also main earth from battery to bulkhead near wiper motor inspect clean etc just to be sure? Think theres multi spade earth conections in engine bay on both inner wing panels?
    Basically as a matter of corse, anything with black wires attatched to body, CLEAN IT! then cover with grease, waxoil etc

    I normally clean ALL contact faces to bright metal, re-connect dry, tighten and then daub em with waxoil ontop to create moisture resistance!

    Have you checked fuel pump? run a long fused feed from battery, just to confirm its functioning? just a thought?

    Admins, is a very good question indeed, Does it run with jumper in TEN + GND?? This could indicate a faulty NE2 sensor (2 wire crank position sensor under coolant filler cap)???
    Also another check with jumper removed, is will it BUMP start??? if so and RUNS normally thereafter, could suggest a faulty NE1 sensor (crank speed sensor) in dizzy? ECU then uses the NE2 signal for cranking, as crank rotates twice as fast as cams and hence more frequent signal?

    Another dollop of checks fella but its whats required Im affraid to pin point
    your Mexy's 'NO SHOW' attitude to starting?? :shock:
    back later! kev b.



  • I checked those items today that I could have disturbed during the removal of the air inlet ducting / etc to enable removal of the bumper.

    1. Connected the jumper plus LED , switched on and nothing.
      I disconnected the airflow connector to check if diagnostics would detect this. It did I read 1 long pulse followed by a long gap then second long pulse followed by a long gap then 1 short pulse. This cycle then repeated.
      ie the diagnostics system is working but I have no error signals normally.

    2. I checked the VAF resistances and all checked out correctly.

    3. Checked the air temp resistance. 2.6kohm at I guess 20C (wednesday morning) ie ok.

    4. Checked crank angle sensor resistance. 552ohms ie ok.

    5. Checked EGR valve solenoid (applied 12v and got a very audible click sounds ok) I noticed with my car a short plastic tube had broken off the air cleaner box and the black rubber pipe which should connect to this was hanging free. I've now screwed a short threaded brass screw into where the pipe was attached to the air cleaner box .I previously drilled a hole through the centre of the screw to create a threaded pipe.I've now replaced the black rubber pipe but on the brass screw.
      I don't know what this rubber pipe does. It doesn't seem to make any difference whether connected or not. Any ideas??

    6. I took the top off the disty. This reveals the rotor arm. I cleaned the tip of the rotor and the 6 pick up points.
      One question….... The central carbon rod which comes into contact with the rotor arm is firmly fixed in its housing. With previous cars I've had, this carbon rod has a spring behind it to keep it in contact with the connecting point on the rotor arm.
      Has my carbon rod got stuck and should it be free to move with a spring behind it??????
      I guess this may be my problem.......



  • Wee bit confused, in one sentance you say your LED shows nothing, then you say you unplugged VAF and it starts falshing?

    If when you first switch on and you get one long flash then nothing, that means NO CODES stored!
    Is it just you switching on from drivers seat and getting out to veiw LED under bonnet? in which case you may miss the initial flash for the system check while moving to LEDs location?

    The broken connection on the air filter box you mention is just filtered/clean air supplying the vaccumm system, solenoids, etc it would still function as normal if exposed to atmosphere but would suck up mucky air and hence dust oil etc which would eventually clog solenoid internals/valves.

    Affirmative, as mentoned in my last post, the central carbon brush must be free to move in and out of its location, it is sprung loaded with a weak spring,
    If it is seized, it will have worn down and a gap appeared between it and rotor which the energy from coil will have to jump, hence decreasing its ummmmph! also the coil will have had a harder life as would the 6 lead posts in dizzy cap?

    Is a brass ring exposed around the central brush? and has it a pitted appearance? it should be covered in the same material as cap, but has been spark erroded by gap created between rotor and brush?

    Try to soak brush in alcohol or meths, to try to free it with slight pressure inwards. They're delicate so if it crumbles, NEW CAP TIME anyway!!

    I did turn one from a motor brush on a small lathe once, it worked but was time consuming and a desperate measure :oops:

    Good chance thats your puppy?? please report back either way :D kev b.



  • Hi,
    I guess we sent off posts at approx. same time. I hadn't received your post when I sent mine…
    Sorry for clumsy explanation of diagnostics light.
    I did connect jumper plus LED as per normal then switched ignition on and walked round to the engine. I guess as you say if there is only 1 flash then nothing for no-errors then I always miss this pulse.
    I then decided to create a fault condition and disconnected the air flow (or is it air temp?) connector and got the result in the earlier post. ie. the diagnostic check does work.
    I then checked all those items I could have disturbed and aided by your resistance values checked with my multimeter. All checked out fine.
    I then noticed a small triangular shaped knob on the outside of the disty cap which can be rotated slightly. I then thought this may be a fine tuning adjustment and took the cap off to check. Found, with relief, this knob is merely a breather pipe for the disty.....
    Then cleaned the 6 disty contacts which had a film of whitish crap on them but cleaned up nicely. Then noticed the carbon rod stuck in the top centre of the cap.
    I'll use you idea of dribbling a taj of meths around it gently trying to free it with shaped pliers.(I've got some with V cuts in the jaws)
    So far so good.
    (I now realise that diagnostic checking isn't as comprehensive as I thought.....)
    Again many many thanks for your help



  • Have just removed disty cap and the carbon brush is flush with the top of the brass? tube.
    I've tried dribbling meths to free the carbon rod but no luck so far.
    I'm wondering if it is worth trying very carefully to use a G clamp with a bolt the same diameter as the carbon rod and gently try to push the rod back a shade. Maybe aided by meths this would free up the rod.
    As you say, if this fails I'll need a replacement disty cap anyway.
    cheers



  • It sounds like its made a home in there, using corrosion as a 'bed friend' :D
    The G clamp attack might prove to be too agressive and depending on the degree of corrosion, it may go 'IN' and unfortunately take root in there, never to see the light of day again? If it does, you'd have nothing to loose, and could then drill it out, trying to preserve the spring tho? then find a similar diameter section of ally or brass/copper, and if your eagre to see if this is your starting prob, fashion a temporary shaped item to the original brush,
    just dont make it too long so it overcompresses the spring, about 8mm long should be ok? with a rounded tip at the rotor arm end?
    Worth a try? then if it gives great joy, youll not be miffed about spending £20 on a prestine cap if ts not the prob? (match your cap exactly, theres a few???)

    Kind of hope it is the fault!, in the nicest possible way? :P ??????????????
    kev b



  • OH! youll have to make sure the fashioned brush is attatched somehow to the spring, because as you fit cap itll prob fall out and you dont want that doing a dance inside there as you crank engine over :shock:

    When youve drilled out old brush, and cleaned aperture the spring should pull out with needle-nosed pliers, its cone shaped, and its larger lower coils ensure a snug fit in the hole, a tiny squirt of WD may aid its extraction?



  • I tried forcing the brush back into the brass holder using a 5mm diam bolt with its end ground down to around 4.8mm to fit inside the brass tube.
    Then carefully put the cap in my 6inch vice with a block of wood on the outside of the cap and the bolt butting up against the end of the brush.
    Squeezed gently and pushed the brush a gnats whisker further into the tube.
    No way could I free the brush in the holder.
    Finally gave up and drilled 4 diagonally opposing 1.5mm holes through the brush and carefully broke it up with a fine screwdriver. All of it came out leaving the spring retained by its wider base. Using drills I found one which is a snug fit (4.8mm)
    I believe Lucas chose this diameter for some of their disty caps so I'll look around for a spare. Also there are oodles of square section brushes available from Hong Kong and one thought is buy one 5mm square and whittle down to 5mm round. I'll probably end up buying a new cap off ebay but I'm going to try to fix myself if possible.
    I'll be really peed off if this isn't the actual starting problem!!!



  • Be strong, if it isnt that, its something else :shock: Thing is, the brush/ cap isnt right in that condition so at the very least youve removed the possibility of that letting you down in the future??

    pretty good chance itll improve running too later??? as the coils energy at present is having to jump 2 gaps! one from the worn away brush to rotor arm and then another leap at each plug!!! god knows how many times a second at peak rpm :shock:

    Dont bother with the Honk Kong thing, pop down to any market stall, spcialising in appliance spares and theyll have a box full of every size, shape of motor brush available, they may even have a cylindrical one of 4.8mm diameter? :P good luck, hope yr weekend is a happy mexy one????

    kev b



  • Back to the drawing board…....
    I bought a Lucas type carbon brush of the right diameter and fitted it in the brass tube in the top of the disty cap. I cut it to the right length by pushing it right home then marking the brush approx 1mm above the top of the tube. Cut the excess off with a coping saw. Job done.
    Reassembled the disty plus other surrounding bits and tried to fire up the engine.
    Exactly the same result as before..........The engine turns over and seems to fire once (maybe even on just one cylinder) and then doesn't fire at all.
    I'm not sure what to try next.
    Some questions:-

    1. Does the above failure to start description ring any bells with anybody????
    2. What would you expect if the EMU (ECU?) unit failed??? I realise the engine won't start but are there any indicators that the EMU is definitely the cause??
    3. Are there any test procedures to check the EMU??
    4. Does any body have a spare EMU I could borrow to plug in and check if this is the problem (Naturally I will pay any costs involved)
    5. Is there a check for the ignition coil. I can check primary and secondary resistance but will this guarantee it works?
    6. Is there a check for plug leads?? (apart from a resistance check)
      Any ideas.
      I'm desperate........
      Thanks


  • If it helps and you can pm me your address before tomorrow, I can have an ECU to you sat via work for free bud.



  • Bugger! frustrating to say the least! :(

    Would be very suprised if its an ECU problem :o

    I may be wrong, but dont think you can swap over ECU's without swapping the 'TEMIC' immobiliser unit as well, ie, the one that came with Lori'S replacement ECU??? worth a shot though? although if the 'TEMIC' swap is indeed nessasary and you dont, the ECU will give the same NONE START effect??

    I speak from experience as I swapped just an ECU and the problem went from poor running, to NO START, I then swapped the TEMIC over as well as the chip in the ignition key, and it started? but still had the rough running as with the original ECU so I summised it wasnt a bad ECU (or TWO!!)

    Just a thought !!!! :shock:

    If your getting partial spark? and one cylinder fireing? COIL again??



  • Hi,
    Unfortunately Loris's kind offer didn't work as his ECU is different.
    I'm back to square one!!
    Some thoughts:-

    1. Coil. I need to check again but I think I saw 1 fat spark followed by weaker sparks when my son was cranking the engine. I will get a friend to crank for me shortly and re-check.
      I've not removed the disty previously;only the cap.
      I believe if I carefully mark the disty body to its mounting then remove the disty body I can then remove the coil? With much older cars it's easy to check the coil by dabbing 12v across the primary, connecting the secondary to a plug and checking for a spark.
      Can you do this with the MX-3 coil???
    2. Crank position sensor. I checked the your resistance value and it reads the right value but I think it's a Hall effect sensor and I wonder if the resistance can still read ok if it fails?? Any ideas??


  • ECU different in what way?
    Both mine K862B, 3 yellow plugs. 1.8 V6 1996-1997

    Yes by all means mark it before removal.

    If you forget and remove it , its NO BIGGY as all youll need to do on refit is get somewhere near and then do LEARN procedure by jumping TEN and GND in diagnostic socket. (IF WHEN YOU GET IT STARTED OF COURSE)

    CLEAR YOUR BENCH, sheet of white paper for your removed dizzy GUTS and a camera????? Take pics for re assembly help!

    1. undo 2 x 12mm bolts holding dizzy body to cam box.
    2. Remove cap 3 x 7mm cross heads.
    3. Place cam drive (not mounting flange or round body with O ring) in vice withsoft jaws.
    4. undo 3 x cross head screws and top cover with seals etc

    5. Youll now see hall trigger pick ups and vane discs, with a marker, put a spot on the little hole you see on the top disc with the brass triangle rotor post. VERY IMPORTANT FOR RE-ASSEMBLY!!.

    6. With a GOOD crosshead screwdriver undo the central screw in the brass triangle (mentioned above), ITS TIGHT! when removed youll notice the underside of the triangle has a flat that matches the spindle youve just exposed. Remove the two trigger vanes noting the little pimple on the lower one that MUST locate in the hole on the top one on re-assembly,(it should have black marker on it now?)

    7. Remove from the spindle next, either a tophat spacer, or sometimes just a washer?

    8. Now with gentle lifting,remove the hall trigger unit, it is held now only by a male and female spade conection? INSPECT this for corrosion etc?

    9. The coil in its entirety is now visible for your pleasure :lol:

    The CRANK ANGLE sensor I believe is a magnetic inductive pickup device. and sends 'resistance' change info to ECU? whereas the CRANK SPEED/CYLINDER No 1 position sensor in the HALL trigger unit youve just removed is a hall effect signal, producing a small 'voltage' change as a signal at ECU?
    It is very difficult to test these without special equipment like ultra sensitive meters or oscillascopes?etc

    HAVE YOU TRIED BUMP STARTING THE CAR?? (see my prev post on this topic dated 24th APRIL! ) OR WITH TEN and GND jumped!!

    Re read some of replies to refresh possible checks you may have overlooked??? :oops:

    Hope this helps??? :P



  • @c6b101a394=blackmexyv6:

    ECU different in what way?
    Both mine K862B, 3 yellow plugs. 1.8 V6 1996-1997

    Wait, it's an OBD 1 car? for some reason I recall reading it was OBD2!

    In that case, ECU would work and it's in the post on Monday.



  • Hi,
    STOP !!!!!!
    I've been working on the car today and checked for spark (no problems big fat spark since I fitted a new carbon brush in the disty cap)
    AND I checked cylinder compression.
    Measurements:-
    80 / 130 / 75 / 90 / 90 / 90 ….......... these are lower than I measured about 1 week ago......

    I'm confident the measurements are ok as I checked pressures on my Yaris and all 4 read 180psi.

    I guess it will not fire below 140 / 150psi so this is my problem.

    BUT I don't understand why.

    I took the car off the road end January after doing a pre-MOT check. The headlights were cross-eyed and the reflectors had come adrift.
    I refitted these and then decided to start the car so as not to run the battery down while aligning the headlamps.

    The car wouldn't start and hasn't started since.

    The oil level is fine and it looks ok (what I can see on the dipstick)

    I guess I could do a leak down test to check if it's rings or valves or look around for another engine. Any ideas??

    Many thanks for your kind offer to send the ECU but I'm now sure mine is ok.


 

Copyright 2019 UK-MX3.com | Powered by NodeBB